(https://lemmy.ml/c/linux) @programmerhumor !programmerhumor@lemmy.ml
(https://lemmy.ml/c/linux) @programmerhumor !programmerhumor@lemmy.ml
(https://lemmy.ml/c/linux) @programmerhumor !programmerhumor@lemmy.ml
Fortran, really.
In Fortran, variables beginning with the letters i
through n
have integer type by default, whereas all other letters imply a real-number (floating-point) variable. You can change this by declaring a type, but using i
for a real is non-obvious.
(Hence the old joke, "God is real — unless declared integer.")
idk, this arbitrary i-n range behaving differently than other variables sounds like a terrible source of weird bugs to me. I don't think variable names should ever change a program's behavior.
edit:
Many old Fortran 77 programs uses these implicit rules, but you should not! The probability of errors in your program grows dramatically if you do not consistently declare your variables.
in programming, and in mathematics, it's always been weird to me that frequently paired variables are basically the most easily confused for one another pairs, especially when written quickly or sloppily.
exactly, this is so annoying. I don't know by first-hand experience, but I also think p
and q
are confusing for dyslexic people.
I think your problem is with the alphabet, friend
M as in mancy
I always like to joke in coding interviews that I really like to make variable names as long as I can so they are very precisely named. Then when I get to a double nested loop I hit them with iterator and jiterator instead of I and j
Unless they're indices, do yourself a favor and use meaningful names instead.
I avoid index iterations the most I can tbh. And for nested loops,i
and k
is more readable.
Even for indexes I do index
or something more specific for what it's indexing. Any simple iteration I just do map
or each
so the only time I ever need to actually index things is for more complex scenarios in which case it's worth it to have better names. Also with modem IDEs, auto complete is really good so you don't need to write a full variable name more than once.
When I was a baby coder back in the 90s we were taught that these names were meant to save space in the symbol table because at one time space was so limited that naming your variable n rather than numElementsInArray would have an impact
This is the way.
i for index or iteration. Using j, k, l... in loops signals (imho) that there is most likely an outer loop and the one using j, k, l are nested. x and y of course are carthesian coordinates . n is used as amount of substance in SI-unit-system, m is mass, maybe thats why it is used as amount of items in a set (Menge).
Programming computers have started to solve mathematical problems and math already used these symbols for centuries(?), so why you should change them? They are well established even in simple school mathematics. And at the end of the day a computer is nothing more than a calculator.
x = "Am I a joke to you?";
I haven't used I and J after college
I've hardly ever looped over indices after college. For-each loops solve 99% of real-world problems in a better way.
Hi there! Your text contains links to other Lemmy communities, here are correct links for Lemmy users: !programmerhumor@lemmy.ml
Usually variables like that can be avoided with itterators nowadays. If they can’t I like to use idx
, if they are nested I name them after what they index, like idx_rows, idx_cols
.
I prefer to use K in for loops, but that's just me.